Jump to content
Brother Jaybird

Jaybird Discovers XI (Spoilers Inevitable)

Recommended Posts

It's happening. It's happening!

I purchased a Steam copy of this game over a year ago and have been waiting to complete Heroes II before starting it up so as not to spread myself across too much (like I always do), only to go and put Heroes II on hiatus until a few months ago. So I finally download it and start it up and immediately my sad, old (two-years-old) computer immediately starts to creak and groan under the weight of such magnificence. I convince it to start up a new file, watch the opening cinematic, noting with interest that it's running so poorly that the voice and the music can't play at the same time and have to take turns, and then it freezes. I leave and come back and it freezes on the first frame of the game and proceeds to crash.

Not to worry. I start it up again, reduce all graphic enhancements as much as I can (the framerate has a minimum base of 30, which is unfortunate; as Heroes could go down to 20), and now it plays like absolute molasses.

But it plays, thank God.

I have no idea what the hero's name is, so I named him Eleven, after the convention of the heroes of VIII and IX (Eight and Nine are their actual names, which is much less cool than I thought it was when I was fourteen). If he has one, don't tell me, I wanna see if I can figure it out for myself.

I've actually managed to avoid most of the spoilers for this game, even listening to Slime Time, and I think I've forgotten most of them, and that still leaves 99% of the game for me to discover! New monsters, new places, new people!

New people like Gemma, our childhood friend.


I like her already.

What I don't like is that after this she exhibits more potential than anything really appealing. She's harmless, but the "what would I do without you" bit kinda highlights the fact that she's not making a real contribution. I don't need her to fight, goodness knows we had our LOYAL ATTACK DOG (Sandy Model) for that. (I say with no guile or irony that I firmly objected to the slimes attacking my dog. I don't think I've ever been that mad at a slime. Maybe the anxiety of not knowing Sandy's HP helped). But for all intents and purposes Gemma spends 90% of the climb as little more than an exposition device, and I'm not getting anything as appealing as Erinn -- who nursed the DQIX protagonist back to health, escorts elderly relatives through danger, runs an inn by herself, never complains, is absolutely willing to put Ivor in his place, and is also hospitality incarnate. So far, Gemma's been much less helpful, and considering the first scene of the game is us cleaning up her mess, she should really be working harder to justify herself. She did furnish me with a phial once in battle, and does a decent job playing big sister to Cole, but I was level one and all I got out of it was 2 MP. Maybe I got unlucky and she possibly was supposed to save it for later, after I'd earned Frizz. I like her, I just really want to like her more. She has a big bandanna to fill.

It's (hopefully) way too early to finalize an opinion -- all I've done is climb the Tor and then saved in the Cobblestone Church -- I haven't even finished talking to all the townspeople.

The new take on combat is interesting. I haven't yet been explained the purpose of wandering around (don't explain it to me!) -- I tried experimenting with placement to see if I could hit multiple monsters at once, but the game didn't see fit to honor that and only let me slay one Slime at a time.

I probably had it easier than true vanilla DQXI would've allowed for. The first time I opened my inventory to check out my freshly dropped Medicinal Herb (which plummeted right down out of the heavens, an image that still makes me chuckle) and discovered that I apparently had an extra Greatsword and some Trodain gear.


Hey, look, Orange Bandanna Buddies! There should be a club.

And if those outfits don't match as well as they might, well, Gemma doesn't dress like anyone else in Cobblestone, so why should she match us?

Anyway, I am definitely looking forward to playing the rest of this game, though with my computer, progress will undoubtedly be glacial.

Edited by Brother Jaybird

Share this post

Link to post
Share on other sites

This post was a fun read!


Looking forward to more!

  • Like 1

Share this post

Link to post
Share on other sites

Ah, another first timer! Enjoy the game where everything is great and it's happy and lovely world where everything is fun and bright.

  • Like 1

Share this post

Link to post
Share on other sites
1 hour ago, DrippySlimeStar said:

Enjoy the game where everything is great and it's happy and lovely world where everything is fun and bright.

You say that, but I saw enough anti-fun and not-bright in the prologue to know you ain't on the level. (Well, okay, arson fires technically are bright, but that's a condition of all flame).

  • Like 2

Share this post

Link to post
Share on other sites
On 2/20/2020 at 1:34 AM, Brother Jaybird said:

I have no idea what the hero's name

Oh that’s easy. It’s MopTopMo.

If you’re playing the Switch version, it’s MopTopMoS!, so it sounds exciting and new.

Finally, if you’re playing in 2D mode, it’s TwoDeeMo.


Those are the one true names for the hero of DQ11.

Edited by YangustheLegendaryBandit
  • Like 1

Share this post

Link to post
Share on other sites
Posted (edited)

And on this episode of the adventures of Moptop Mo, Gemma still ain't doin' it for me, bless her heart. I keep wanting her to do it for me, but she's just not getting anywhere.

So now that I've had a chance to get a good look around Cobblestone and talk with all the people, it's become painfully obvious that the game is shipping Gemma with you. All the townspeople are sure the two of you are a thing, and while Gemma isn't annoying and clingy about it (bless her), this game is demonstrating a fundamental failure to understand romantic tension. There has to be pushing together and pulling away, and all this game is doing is pushing. Gemma's not pushy about the two of you like all the other village women are*, but that's just another thing Gemma's not doing. Even when the game is trying to use her to pull at my heartstrings, but the memory she chooses to share is us running off to get her bandanna as children, because a lifetime of cleaning up Gemma's mess is clearly a winning formula.


* All the women except for Cole's mom, that is, who makes the act of bending over a stove a lot more flirty-looking than is really appropriate. I should be having this kind of moment with Gemma.

Gemma... really kind of fascinates me, in that I'm caught wondering by what she's even supposed to be. She clashes so completely with the established setting of Cobblestone (doesn't wear the cobblestone costume, is the only blonde around for days) that I have to imagine she's foreign in some really important capacity, and yet all she wants to do is live in the village where she grew up. Is that paradox intentional? I want it to be, I really do, but the game's not even hinting at anything with even a whiff of foreshadowing, and this is not an especially subtle game. Gemma's stuck in this spot where she radiates potential, but a point hasn't even threatened to emerge. Hell, that weird door in the corner of the village with the three circles on it is more obviously foreshadowing something than Gemma. Gemma strikes me as kind of a failed heir of Saria from The Ocarina of Time, a clearly important member of this remote woodland village who has a clearly close relationship with the protagonist, but rather than using the surrounding villagers to illustrate your shared relationship and activities and then developing the relationship with the poignant parting scene like Ocarina, DQXI just takes your supposed relationship and its appeal for granted. Mostly I just feel sorry for Gemma. She could've made a good party member in a different story.

So, ma (who also dresses foreign) finally tells us we're adopted, and we head out into the world, wondering why Grampus Chalky ditched us and why Gemma's Grampus Mayor Dunstan doesn't want to admit that we were found floating in a river even after the whole village knows we have a destiny. I switched back to the regular clothes, because the Trodain outfit is neat, but should be worn by Trodainians. Besides, ma made me some neat adventure clothes, and I gotta look neat and sharp. Gemma, who thinks destiny sucks, nonetheless finally did something and made me a charm, which I will wear forever in remembrance of the one thing the story's allowed her to actually do, and wonder that maybe if I play the right song on it I can mind-meld with her. My other accessory slot will be occupied by a DLC item that came with the Steam release that gives me 1 MP every turn and thus basically infinite Heal spells. The next two hours of gameplay destroy me.


Thank you, Gemma. I proceed to slaughter my way to Holodomor Heliodor, taking special care to hunt down every needler in sight, because those are the most unholy things I've ever seen in a Dragon Quest game and are to be torn apart with extreme prejudice. I feel only slightly guilty for killing a platypunk at night in its sleep and made up for it the next day by finding one that was awake and sneaking up on it from behind.


Interestingly, I see that they've bowdlerized the cruelcumber death animation, in which their spear goes flying up in the air before falling to earth point down. In XI, the cruelcumbers catch the spear before it hits them, while in IX, they, er, don't. I'm ambivalent one way or the other to it, but I can see why you wouldn't want that IX version fully animated in such high def in front of the kids. A nice old man teaches me how to camp and that I can pray to statues for salvation (actually being Catholic makes this mechanic really obnoxious), but then I find something fascinating.


So I find this little guy wandering in the direction opposite the emerald coast, so once I go check the emerald coastward path out, I come back and discover I can't interact with him at all. Which is probably for the best, since the last time I saw one of these guys, the prolog happened. But he's clearly here to be guiding me towards my destination (which is a neat but kind of pointless flourish; I know where I have to go, and I'm at a fork in the road with one branch blocked -- I really don't need to be guided to where I'm going).

After taking the time to fully explore landscape and slaughter the monster population, I finally end up in Heliodor, and get very distracted by all the beautiful figures.







This is probably a good time to discuss some of the setting's mechanics. I discovered that I could destroy certain barrels and pumpkins back in Cobblestone, which was cute the first seven times but has yet to really add anything besides highlighting the classic joke of the hero ransacking every house he can enter for goods, and this doesn't even give me any goods. A much better flourish on the same joke is me going through an old women's cabinet right in front of her and appropriating a pair of fishnet stockings she clearly had no business wearing (the idea of Gemma as a party member becomes more appealing by the second). The jumping mechanic is, er, primitive, and with the myriad invisible walls makes some of the exploration frustrating -- the game successfully has convinced me that the world is a big place, and I know I can't explore all of it, but I'd prefer the game not rubbing my face in all the places I can't go, like showing me all these doors that are impossible to open. Screw you, game.

There are some more of the little blue ghosty-guys around town, just hanging out, which is neat so long as nothing burns down again, but while I explore, I can't help but notice how everyone is talking up the city's heroes and I encounter at least two bits of information on the local prison, including the note that the  prison is inescapable, so I know where I'm going to end up soon.

So I finally get around to my meeting with His Majesty, like Grampus Chalky wanted, dressed in the finest things ma could make for me.


Screw you, dame.


You've clearly never played an RPG before.

So in case all the talk about famously noble heroes and the local prison didn't tip you off, my meeting with the king goes pretty darn south, but there's a pretty neat twist in how they carry it out -- the good guys are actually good guys, and they think I'm on the level about the whole Luminary bit, which means they think I'm evil.


Listen up, you smug walking hairdo, I'm not morally authorized to punch your lights out yet, but I really want to be.

So I get thrown in jail over what doesn't seem to be a misunderstanding, and Punchable Face the Hero is off to apparently go burn my village down; I'm clearly in for a miserable future. (I have to give it to the game for giving it the extra edge of involving the village. Mayor Dunstan is in for a bad time).


Well, at least prison won't be boring.

So the hooded stranger busts me out with a not-quite-charming, not-quite-obnoxious level of ease, and proceeds to mention something about a Seer while he leads me on a merry game of sneak past the guards (another Ocarina of Time comparison!). I rather like this take on the traditional prison scenario, which takes place when you're an obvious weakling in the face of a half dozen armed guards, as opposed to other games in Dragon Quest where you'll have slaughtered a few giants by the time you get thrown in jail and so have no business being thrown in jail. The stealth section is short enough, and goes off without a single hitch.


Like I said, without a hitch. While my hooded assistant isn't quite as appealing as Gemma's LOYAL ATTACK DOG (Sandy Model), he has basically infinite health and hits almost as hard as I do, so it's not like I'm floundering here. We leave the sewer-prison and end up washed up on the shore in front of a salvation statue, Mr. Hooded Guardbeater mumbles a few lines about fate and seers and we might just have a theme to this game.


Me, too, kid.

Edited by Brother Jaybird
  • Like 1

Share this post

Link to post
Share on other sites
On 2/20/2020 at 2:34 AM, Brother Jaybird said:

Maybe the anxiety of not knowing Sandy's HP helped

I don't know if this was pointed out, but I'll go ahead and let you know that NPC party members don't actually have HP as far as I can tell. I've seen them take nearly 5x my max HP in damage without healing and they never died, so I'll go ahead and say with utmost certainty that NPC party members basically become damage sponges that make enemies waste turns.

Share this post

Link to post
Share on other sites
7 hours ago, Brother Jaybird said:


Fixed that for you. 😘

Share this post

Link to post
Share on other sites
Posted (edited)
1 hour ago, YangustheLegendaryBandit said:

Fixed that for you. 😘

His name is BowlcutBob.  Though his nickname around Costa Valor is StrawhairStan, and in Hotto, LankyLarry.

Edited by ignasia

Share this post

Link to post
Share on other sites
Posted (edited)
42 minutes ago, ignasia said:

His name is BowlcutBob.  Though his nickname around Costa Valor is StrawhairStan, and in Hotto, LankyLarry.

BowlCutBob is his one true name in Japan. The other two are slanderous names to call him. How dare you repeat them here.

Edited by YangustheLegendaryBandit
  • Like 1

Share this post

Link to post
Share on other sites
7 minutes ago, YangustheLegendaryBandit said:

BowlCutBob is his one true name in Japan. The other two are slanderous names to call him. How dare you repeat them here.

Not that I made the up or anything.  I can't help it if NPCs also call him PotPinchParry, and Randyhomeraider.

Share this post

Link to post
Share on other sites
Posted (edited)


Edited by Brother Jaybird

Share this post

Link to post
Share on other sites

Welp, so much for that. There are some odd placeholders in there because the forum won't let me edit the post any more. Sorry, everyone.

LankyLarry's tale,
it does henceforth continue.
Behold the journey.


So less than five hundred feet away from the salvation statue, I started to get a funny sensation in my stomach, like the exit would be harder to get to than expected, brief respite notwithstanding. You ever get one of those sinking feelings sometimes?


'Cause I do.

So me and The Man from HOOD get chased through the caves by some newly discovered relative of the Great Dragon. Unlike the guards, I did not see fit to actually challenge the dragon, as the game seemed determined to run us through the set piece and I figured it would be less painful to just run with it. Or away from it. (I note with some chagrin that the game taunted us by dropping half a dozen metal slimes just out of reach while we were running for our lives).

We escape from ??? to safety.


Ha! Fooled you! The game subverted our escape from having to flee the guards by having us escape right back to fleeing the guards! Hahaha, what an intelligent expenditure of player time!

We could easily have done without the dragon sequence. It really adds nothing except foreshadowing what will probably be a middle game boss fight. The mystery of the king of Heliodor (and his affairs from the prolog) is a vastly more intriguing thing than the fact that there happens to be a dragon in a cave, even if it's a very specific cave.

So the guards chase us through the sewers/catacomb/necrogond and we end up emerging from a tunnel next to a waterfall. The Man from HOOD, clearly a thief and lifelong cynic, makes the smart, rational choice and figures on negotiating with the guards, who don't actually want us dead.


Oh, this is going to be a painful relationship. So the fideistic flatskull here has basically latched on to me as the messiah, bless his heart, which I'm pretty sure should earn him a spot on the shortlist for the local end-of-days suicide cult. Never tell this man to jump off a cliff.




Complicating things is the fact that I am, in fact, the messiah.

I'm really not digging Erik's "character development", if you can really even call it that. He's some rando who spent months in jail (basically capable of escaping at any time, as he clearly demonstrates when he punches out a guard through the bars of his cell) on the word of a seer, and the predicted Luminary finds him on the last day of his task, and the most he has to show for it is mild shock. Even if I didn't find the subject matter of his faith in a fictional messiah distasteful, there's nothing in his character remotely appropriate to the situation -- no exhaustion, no lingering doubt, no frustration, none of the cynicism appropriate to his vocation, no annoyance at himself for what to a normal person would take as the mother of all fool's errands, just a moderate quantity of "Neat! I believe in you, now!" His development is undercooked at best and insincere at worst.

Secondly, what does putting his faith in the Luminary even mean? On what actual grounds does he have to think that plummeting thousands of feet won't kill him instantly? Is that a promised power of the Luminary? Erik just sounds more and more like an authorial sockpuppet talking nonsense about faith to highlight my status as the luminessiah. (And to be pedantic, yes, he does have a choice -- taking on the guards is something I know both characters are more than capable of doing, and even giving up is an option let's him stay alive for at least a little while, as the guards clearly object to the characters plummeting to their deaths).

So Erik ends up Saved By Faith, and drags me off to a nun, whom we end up lying to and sneaking away from awkwardly, and it turns out he has an errand to run back in Heliodor, and for that we'll have to sneak in.


So once this failed Final Fantasy audition finishes giving me advice about not standing out in a crowd, we return to the seedy underbelly of Heliodor, where Erik finally starts acting like a thief, not that he'll actually use the word. We meet Rose, and Roxy, and Cammo, who insists Rose used to look like Roxy, which is very nice to think about, but really the neatest thing about Rose is how Erik flirts with her, which is a much more whole and wholesome relationship than he ever had with me. We also briefly get to sample a new Loyal Attack Dog (Bullseye Model).

Unfortunately, we also return to Erik's "faith" theme, where once he fails to find the Orb, he immediately latches onto his conviction that his old partner in crime, Derk, has double-crossed him and run off to a life of luxury, which is mostly believable, except the game makes a point of repeating Erik's understanding of the situation and inadvertently foreshadows the coming twist that Erik will be wrong. (I don't really hold this against the game; it's fair to say I'm probably genre-savvier than the target audience).


And wrong he is; so it turns out Derk accidentally went straight trying to solve the Erik's In Jail problem and gave the stolen orb back for the reward and has since become a merchant; even took a wife (who is a little odd -- I'm pretty sure most wives stop referring to their husbands as "magnificent" a few weeks after they start dating). Erik apologizes for doubting, expresses minimal self-reflection on his tendency to latch onto his beliefs, and ends up with a second relationship that is also more worthwhile than anything he shares with me. I turn out to be a pretty crummy luminessiah, happily agreeing to help Erik Notathief re-steal a treasure of the kingdom that imprisoned me.

But first we get to return to Cobblestone and see if Gemma gets a better part in the story! (No, seriously, I will happily trade Erik for Gemma, I still have a pair of burgled commandeered fishnet stockings just sitting in my bag). We have to take the long way 'round, though, as the Heliodoran army wouldn't like to see us; through the Manglegrove we go, finding new monsters and talking cows (it's good to see Dragon Quest taking so much inspiration from Ocarina of Time, really makes it a modern feeling game).


Moving past the several uncomfortable questions this raises about the production of meat, along the way we get the Fun-Sized Forge (which is more fun than I originally thought it would be, though I lament the apparent abandonment of alchemy; at least the Great Krak Pot talked to us), our first boss, and a new superpower! So one of the benefits of being the Luminessiah is that the glowing tree in the sky really loves us, so if we encounter one of her bejeweled roots, which show up in random locations and are totally not an object of poaching for some reason, she shares her save states with us. This allows us to find and kill the Tricky Devil, who was hiding in an empty treasure chest that really was empty when I passed by it the first time, which frees the Woodcutter from being turned into a dog (which the Tricky Devil never tried to do to us, go figure) and allows us to continue on our way. Another benefit of being the Luminessiah? Great hair.

A last couple of notes before leaving the manglegrove: everyone has a unique dancing animation, which is neat, and I'm still hyped about that Cyclops I saw on the deeper jungle floor.

Anyway, finally we get back to Cobblestone, and let me tell you it is great to see everyone again. Unfortunately, not everyone seems to feel that great about seeing me. They don't even recognize me, for some reason. Maybe Mom knows why.


Aha! We've gone back in time! That's what's going on. (This was really sudden). Thanks, Mom! (I am a little underwhelmed by the game directly reusing mom's model, which is not only mildly insulting to the woman, but accomplishes nothing except to delay the twist by about ten seconds).

Oh, well, we can't go home again, but we can still walk and talk and see what was going down when the old haunts were still new.


She's adorable. You're cute, too, Gemma. Here, let me clean your mess up for you. (I'm glad to see that the creators gave you a new model; at least they put some effort into your character).


Oh, no, you don't. I don't care how much your cuteness intensifies, Gemma, you won't distract me from the fact that I just broke the whole timeline over my knee.


I hear the sound of Dragon Quest V intensifying in the background, but it's nice to know that we had at least something of a personality once upon a time. I can totally understand a six-year-old girl who loses things in trees getting along swimmingly with a six-year-old boy with a ladder. This is the stuff crushes are made of. Also, grampus Chalky is here, too.


Don't you look at me like that, old man. Don't sit there and pretend you've adapted savvily and mysteriously to this whole affair. This town already has a couple thimble-deep mysteries to it that I still have to solve and cute blonde who could've been really cool in another timeline, I don't need you complicating that.

So, anyway, it's a nice treat to see Grampus Chalky again, and we discuss timeline matters for a bit; he drops a vague line about being "no longer around" in my time and gives me instructions to go dig up some buried treasure... and then he vanishes, which raises some pretty radical questions about how this Inexplicable Time Travel works.


So apparently it's time to go all of a sudden. I get to see the kids one last time, and I'll admit I can totally see why the village ships them. But anyway, we're going back to the future! Now we'll get to say hi to everyone for real this time!



This is a terrible scene in exactly the right way. It's legitimately upsetting, in the same way DQV was, and for most of the same reasons. It's even staged well, using the transition from the past to the horrible, horrible, present.

I'm starting to think the Heliodorans may not be quite the heroes they're touted to be. The "good guys" sure seem to be good at viking raids.

Unfortunately, the scene also highlights a core weakness of the silent protagonist and possibly the story, in that an actual human would be completely distraught and horrified, but the luminessiah turns out to have the emotional depth of a teaspoon. Erik's response is also rather weak, especially considering he's supposed to be emoting for the both of us, but at least it's accurate to the situation. It's also kind of morbid to just wander emotionlessly through the ruins of your hometown and help yourself to the loot now available in the ruined church. We have one of the most horrifying occurrences in all of Dragon Quest history right in front of us, and it gets written off in the scene of one cutscene. Nobody dwells on the horror of the event, nobody expresses any hope or desperation that someone might've survived, it just happened and we only technically acknowledged it before moving on. (DQVII was much better about this sort of thing, with Maribel actually being noticeably affected by the fear and misery you encountered).

Erik thinks that our trip to the past was a souped-up vision from the local Yggdrasil root, which isn't carrying a jewel, but has hidden sigils anyway, and it turns out there is buried treasure containing information from our trip to the past, which raises still more questions, like how does the time travel affair work? Was this information always here in this timeline, have we modified the past and wound up in an alternate timeline, exactly how alternate is this possibly alternate timeline, given that Chalky knows that the once-recommended trip to the king goes south, what is even going on? (Incidentally, we're the prince of a kingdom that doesn't apparently exist anymore; I've been selling every bit of my true homeland's currency as a cheap curio).

I want to pause again and take note that we have two different mentions by Chalky of "don't hold grudges" within ten minutes of each other, and I seem to recall someone attributing it to him earlier in the game, so that may end up being the theme of the game, rather than Erik's psychological problem. Also, "I'm just an ignorant old man from a little village in the country"? Grampus Chalky, you are the most blatant liar I've ever known, Mr. Here-Have-a-Keystone-that-opens-Magic-Doors.

In hindsight, this is a game with a lot of intrigue (and scenery), but the character development and emotions could really, really use some work.

But anyway, we go back on the road to re-steal a treasure from a kingdom that employs apparent mass murderers as heroes, because the luminessiah's word is his bond. There's a tent out in front of the kingsbarrow with a book we can't read, which is unfortunate, so let's go see what they're up to.


I see you boys had quite the party, huh? How'd it go?



So there's trouble afoot in the kingsbarrow, and we do the dungeoneering thing. The dungeon is pretty straightforward, minimal branching, some external areas, but near the end we are introduced to the new mechanic of steeds, which promises to be fun.


It is immediately less fun when the direct implication is that we scooped out the eggoskeleton's guts. 

So the heart of all the trouble turns out to be a couple of grim gryphons who are also after the red orb (and are really quite inefficient about getting it and skedaddling) trying to get into somebody's good books (Ha ha~ the game isn't gonna tell us anything!). I like the boss battles with their full voice acting, which is delightful to listen to, and a step up from DQVIII.

Once Erik gets his orb back, he admits he thinks I'm a lucky charm (what, the thousand foot drop didn't do that?) and that he has secret affairs of his own that he totally expects me to contribute to, which is better than all his earlier chatter about faith in the luminessiah, but not by all that much. I'm able to pilot the eggoskeleton husk through the dungeon and past the entryway, where all the corpses have been removed for some reason, but I must abandon it on the outside.

Well, a limited but fun mechanic is still a fun mechanic.

I tinker with the fun-time forge some more and upgrade the Supplicant accessory to +3, so now I get a free 3 MP every turn, which is very useful because I also gave Eleven Zap. My gameplay style so far has been to keep Eleven on Show No Mercy while using Erik to Half-Inch everything in sight for extra loot, which hasn't failed me so far. I like that Erik has lines -- "Yoink!" and "What's yours is mine!" -- but I would like them a lot more if they went along with actual confirmed steals, because when they don't they inevitably degrade into noise.

Anyway, the luminessiah and his looter disciple continue east and are forced to abandon our horse to make our way through some undergrowth. We emerge into a clearing with some hades condors (looks like 'em anyway), but we're not allowed to explore this section (shame on me for not checking earlier), because a chase scene finds us.


Hax! I call hax! There's no playable horse in the game that could climb up those rocks, and how dare you flaunt your unicorn armor in front of me when I just abandoned my own horse, which is totally a gift from the town you apparently razed to the ground and not a generic steed that just shows up when I ring a bell.

So Hendrik and his goons, whom, remember, we have pretty good reason to think might be horrible mass-murderers and psychopaths, not that we bother to talk about it, chase us across the clearing, which is a little silly because I saw the size of the clearing and there is way too much chase scene for this tiny spit of land, pretending it isn't also ridiculous that the horses don't catch up to us when we're on foot, and that it isn't worse when there just so happens to be an extra horse standing around waiting for us to commandeer it, and further when Hendrik shoots the dumb horse from nowhere, knocks us to the ground and still can't catch us. I abandoned my horse to steal a horse and the second horse got shot. Would it really have been that awful to just let us walk across to the door?

So the door hides a portal and the portal sends us very far away, to a rocky place with a very beautiful active volcano nearby. I do love me the bongo drongos with their chimpish drums. But most importantly, time to sweat!


Hotto is a hot land
of large and restful saunas.
Erik quickly departs.

I do not depart,
but make up for my past lack
of exploration.

I thought we were lost,
but foreigners are here, too.
Not as lost as thought.

The house of Tetsu,
who found the Mini Medal.
What is his is mine.

Little redcap bites,
and bites again with her tongue.
Deal with her later.

I find Miko soon,
above us in her temple.
Deal with her later.

I soon find the bath,
and am strictly forbidden,
from going astray.

But not little girls,
who may wander in at will.
Good thing we're all clothed!

I find the Puff-Puff,
but this time was not a trick.
Connie's right there, too.

It is much too bad
that the girls' sauna has such
poor security.

Redcap in the square,
causing more trouble for all.
Connie's not her sis.

Redcap's sis is lost,
in monster hands, most likely.
She tags along now.


Meet the silent deer,
who do not share the weather
and won't interact.

Despite her big stick,
redcap does not speak softly.
Can't hit hard, either.


We climb the mountain,
and find one foe to challenge.
This was a mistake.


We explore elsewhere
and find the robber rabbits.
Cute, but no real threat.




Time is lost to find
another rabbit rare drop.
I lost mine to death.

We find the monsters
and their faraway hideout.
Erik sure is spooked.


Ah, such a good find!
An unattended chest here;
I'll just go get it.


A new type of steed,
with new and unique motion,
but only one use.

Inside a chest here,
a robber rabbit's rare drop.
I kick myself hard.

I believe this place
was once a temple, with the
root and the statue.

Redcap and greendress,
make quite a pair united.
Let's kill a dragon.

We have a name now,
the Lord of Shadows it is.
Redcap's still tiny.

Arboria's name
reminds me much of Arba.
I miss King Doric.

Connie's dad is free,
but, wow, is he suspicious.
Poor, poor, poor Connie.


We corner Noah,
pretending to be a drunkard.
Props for the mean look.

We save with the priest,
the missionary nearby.
We will resume soon.

  • Like 1

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...