Jump to content
Sign in to follow this  
Woodus

Database crashes

Recommended Posts

So I guess the MySQL server (#1) that the Den was on to begin with started having issues and corrupting data back on April 6, they restored, corrupted again, did a couple more restores and kept corrupting

 

So they moved all the databases to another MySQL server (#2) and things seemed to be working, except we lost those 2 months of data from April to the beginning of February. Asked for a restore to the new server.

 

Now here is where it gets confusing for everyone, somewhere along the lines #2 started having the same issues as #1, so they moved it again to #3, but they didn't tell me they moved it to #3. So I kept asking for restores because the data was wrong (April 10 with missing posts), but I kept asking to restore to #2, because I didn't know things had moved to #3 and they didn't change the config files to point to #3.

 

Finally this we got to speak to Tier 2 (that was a chore to get done) and we figured out that everything should be on #3 and the last few restores I asked for had been done to #3, so we manually changed the config files to point to #3 and lo and behold there is the April 5th un-corrupted data (today about 2 PM Central).

I thought about doing the upgrade then, but knew I had a long week at work next week, will be traveling the weekend of the 29th, figured it couldn't hurt to get everyone back in and stress test the current setup, plus I cannot take my own database snapshot (was working before the crash) so I didn't want to risk the upgrade breaking the database without my own copy.

 

Once remote MySQL access is working again I plan to script on one of my home computers to take my own nightly snapshots of the databases (forums and den) so I have my own working copies I can restore from.

  • Upvote 5

Share this post


Link to post
Share on other sites

I understood about 50% of that, but that's OK. We're back!

  • Upvote 1

Share this post


Link to post
Share on other sites

I don't know if I really understand it all yet >.<

  • Upvote 3

Share this post


Link to post
Share on other sites

I work in IT and I still didnt understand it all.

 

Sent from my LG-H820 using Tapatalk

Share this post


Link to post
Share on other sites

All I know is the mobile version of the site is at war with me right now. I have to keep signing in and hope the next time will be the last.

Share this post


Link to post
Share on other sites

All I know is the mobile version of the site is at war with me right now. I have to keep signing in and hope the next time will be the last.

It's not just the mobile version, I'm having the same problem on the desktop version on my laptop.

Share this post


Link to post
Share on other sites

I'm having the log out problem as well on my phone with "Keep me logged in," checked. It only logs me out when I close my web browser app.

Share this post


Link to post
Share on other sites

I have also noticed that I have to log in frequently.

Share this post


Link to post
Share on other sites

Okay, so I just want to say I don't care all that much about the problem if the solution is taking down the Den for another half month.

Share this post


Link to post
Share on other sites

Yeah, I don't want the den going offline again over this. PLEASE, not another black out.

Share this post


Link to post
Share on other sites

Have you tried clearing your cache and cookies?

Share this post


Link to post
Share on other sites

Have you tried clearing your cache and cookies?

I just tried doing that and after a few tries of opening and closing my web browser app it looks like the problem has been resolved. Weird that was happening. Any idea why that was happening prior to clearing my cache and cookies?

Edited by YangustheLegendaryBandit

Share this post


Link to post
Share on other sites

In other words, #1 started to fail. #2 was then brought in as a replacement but then suffered similar issues, and when you tried to remedy said issues #3 replaced both #1 and #2 without your knowledge of it. But hey, least it works now...knock on wood. XD

Share this post


Link to post
Share on other sites

In other words, #1 started to fail. #2 was then brought in as a replacement but then suffered similar issues, and when you tried to remedy said issues #3 replaced both #1 and #2 without your knowledge of it. But hey, least it works now...knock on woodus. XD

I had to make a small correction.

 

Either way, I'm glad the site is back up. I need my fix

  • Upvote 1

Share this post


Link to post
Share on other sites

 

In other words, #1 started to fail. #2 was then brought in as a replacement but then suffered similar issues, and when you tried to remedy said issues #3 replaced both #1 and #2 without your knowledge of it. But hey, least it works now...knock on woodus. XD

I had to make a small correction.

 

Either way, I'm glad the site is back up. I need my fix

 

 

Haha, didn't think of that when I posted. I'll have to keep this joke in mind. 

Share this post


Link to post
Share on other sites

:P 

Share this post


Link to post
Share on other sites

I work in IT and I still didnt understand it all.

 

Sent from my LG-H820 using Tapatalk

 

Likewise.

 

However, we're back and that's all that matters.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...