Jump to content

Recommended Posts

I am at Rydon's tower and I am currently stuck.

 

I'm on the floor right before the ladder with the red bridge. You're supposed to pull the statue where the bridge drops down, run back up onto the bridge and then pull the statue onto the bridge so you can run up it. So, I do this and the game doesn't let me move the statue when I'm standing on the bridge.

 

I have tried everything I can think of to get the statue onto the bridge but nothing has worked. Does anyone know if this is a bug or am I just doing it wrong? I've googled around and saw nothing like this, it should be a really easy puzzle so I don't think I'm doing it wrong.

 

If anyone has any information to help it is appreciated. Maybe I'm just dumb but I had no problems on the ps2 version.

 

Also, hello everyone. It's been many a years since I last ventured forth in these forums.

  • Upvote 1
Link to post
Share on other sites
  • 4 weeks later...

For those wondering the solution, you have to pull the statue onto the little square at the foot of the stairs. It should move the statue up to the fifth floor, allowing you to push the statue onto the seesaw.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...