Jump to content
Sign in to follow this  
dormando

Hosed by 2.1 Update

Recommended Posts

The 2.1 launcher update ran, now every time the launcher fires up it immediately crashes out.

 

Anyone else on PC run into this issue?

 

I've completely uninstalled the game and re-installed it and rebooted and whatever else windows usually wants you to do. Moved the DQX folder in the documents thing out of the way too. Every time I re-install, it downloads the new launcher then immediately crashes.

 

:'(

Share this post


Link to post
Share on other sites

I wonder what's wrong with all the 2.1 updates...

 

I had the following problem and kinda managed to get through it:

http://www.woodus.com/forums/index.php?showtopic=24382&page=7&do=findComment&comment=378784

 

That was yesterday morning (WET)... When I wanted to get back in game yesterday evening, another update was waiting for me. It was driving me insane. My PC kept going into standby-mode and shut down after reactivating during the whole update process. When I finally reached 99% it was going really nuts. I couldn't get the one remaining percent without it doing the standby-shutdown-combo.

 

You know what I did 30 restarts later? I installed the game on my gf's laptop and downloaded all updates. I copied the files to my external HDD and then overwrote my game files (including the setting files in the "My Games" folder).

 

Then it finally worked. But I'm afraid I need to do this again today, as Ashes already posted that there was another maintenance. :/

Share this post


Link to post
Share on other sites

I'm getting the feeling they may have thrown in some sort of content check that's $#!&ing up... I can't tell why the launcher would $#!& up on me, even after a completely fresh install.

 

Is your machine overheating? Update might run the CPU a little hard.. but then again so does the game. Ugh.

Share this post


Link to post
Share on other sites

I don't know... It doesn't seem to be an overheating problem. It's the DQX configurator.

 

When this all started, it was only the configurator and nothing else. Updates and the launcher didn't cause any trouble.

 

But now I noticed that the configurator invisibly opens in the background when I just start up the launcher. Now I even have to hurry when I type my password - if I'm too slow my PC just shuts down in the same strange way as always.

 

The configurator is the root of all evil and for some reason it's force-starting alongside the launcher since the 2.1 update. Maybe I should try to block that EXE-file.

Share this post


Link to post
Share on other sites

Odd. if I start the configurator directly from the game directory it runs fine...

 

... Except it's a bit goofed up for me. I have my locality set and JP language whatevers but for some reason the configurator's menus are all ?'s, and the dropdown menus are full of garbage.

 

How does one block the exe? This just happened again... new launcher downloaded, now when it starts it dies at the same spot. :/ Just want to play the stupid game.

Share this post


Link to post
Share on other sites

Doesn't seem to be the configurator for me.. I renamed the exe and it still hung.

 

Task manager shows it just being the launcher that dies... and a sub process of itself. Like it's trying to fire off the updater exe and can't.

 

What blows my mind is that this is a completely fresh windows install. steam and DQX have been installed on it, and the browser hasn't even been open in months. I haven't even had an opportunity to install or something that it wouldn't like.

Share this post


Link to post
Share on other sites

More things that haven't worked:

 

- Changing the win compat modes.

- Running the updater as Admin.

- Disabling the "this will modify your computer" popups.

 

Just wish I had any sort of hint at all as to what it's doing when it blows up. "This app has unexpectedly hung" worse than useless. Give me a syscall trace, a stack trace, anything...

 

Haven't tried changing the locale back to english. Not sure what else to even twiddle.. like I said it's a very bare fresh install of windows.

Share this post


Link to post
Share on other sites

OH MY GOD I JUST FIXED IT.

 

I've been playing on an intel NUC, which uses some realtek driver weirdness. When you don't have anything plugged into the audiostream it unloads the drivers and mutes. When you do, it loads some drivers. I tend to play DQX without the audio plugged into the NUC.

 

The autopatcher plays some elevator music while it runs. Since the 2.1 patch, if your audio is disabled it just crashes. The new patch came out today, it failed again, and then I thought "well... what if..." and plugged in the damn audio cable. It works fine.

 

Windows. Not even once. :(

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...